GMC Truck Forum banner

1 - 3 of 3 Posts

·
Jack Daniels aficianado
Joined
·
11 Posts
Discussion Starter · #1 ·
On 2/16 I left my grandparents house after dark and tried turning my high beams on… it took me flicking the arm 3 or 4 tries before they turned on, then I tried to switch back to lows and again it took a few tries, after I got out of the city I tried to switch again and it just wouldn’t change. I drove home and when I shut the truck off and manually shut tried to shut the lights off it wouldn’t work. I went inside for 10 minutes to see if it was just the timer setting thing but it never turned off. I changed into some warmer clothes (-30s after windchill) and went out to start playing around. Checked my fuse panels and started to look around. Dad told me to grab the owners manual so we could decipher some abbreviations and wouldn’t ya know, those fuckers at the dealership didn’t even give me one! I was pissed! I grabbed my dads from his truck (04 2500) and we made due. We pulled the headlamp relay and low beam fuses but no change, and it wasn’t until my dad pulled the high beam fuses that the lights finally went out. I still couldn’t believe that even a used car dealership would sell a rig without an owners manual. They have so much important info for people who DIY stuff. I texted the sales guy that I want a book and he said he’d “see what he could do”. My ass, he better find one or steal it from another truck.
Next morning I stopped at Advanced Auto Parts and picked up a mixed pack of fuses and the cheap little fuse tester that comes with them. All the old fuses put back in and they all lit up the light. Swapped them all out with brand new ones and they still all lit up but the headlights still stayed on. I asked if I could have a new headlamp relay to try swapping in and test it. They gave me one but it didn’t change anything…. Grrrrr

Drove up to my girlfriends house and started to play around with the fuses again. It was only the bottom set of lights (apparently the hi beams?) that stayed on when all the fuses were placed back in. I pulled the hi beam L and R fuses and the top set (low beams?) came on. I played with my switch and ta daaaa, I was able to shut the lights off, but only the top set is working. At least now I could drive the 400 miles in the dark and not worry about blinding anybody and I could shut them off everytime I shut the truck off without pulling 2 more fuses. The hi/lo toggle didn’t have any effect on the lights. When I tried to switch the hi's on the lows' stayed on and did not flicker or go off. But the switch would let me shut the lows off, set it on auto, turn the marker lights on, and then actually turn them on.
Anybody have any ideas? I am taking it back to the dealer tomorrow to have them look at it, ive been told possible bad switch? Either the high low toggle or the actual light on/off one. I am kinda stumped and haven’t been able to find much online. any ideas or suggestions would be great

also been told the mice and chipmunks like to make nests under the fuse panel. if i had a place out of the wind i'd pop it off and look around for nest or frayed wires but its too damn cold for that!
 

·
Registered
Joined
·
3,481 Posts
sounds like your problem lies within the multi function switch on your steering column. The one that controls your turn signals and the high beams.

Mr. 960
 

·
Jack Daniels aficianado
Joined
·
11 Posts
Discussion Starter · #3 ·
took it to the dealer where I bought it today. we did a lot of troubleshooting and research. we found 2 instances on Chevrolet forum where 07 suburbans had same issue and both stated that after replacing headlight switch and the cornstalk, the problem was still there. it wasn't until they replaced the fuse block that the issue was fixed. dealer I bought it from agreed to eat the cost of the new block and we ordered it. should be getting repaired next weekend.

if I doesn't I will then go after switches/cornstalk

http://chevroletforum.com/forum/tah...uburban-high-beams-wont-turn-off-32374/page2/




http://chevroletforum.com/forum/tahoe-suburban-25/2007-suburban-high-beams-stuck-57362/
 
1 - 3 of 3 Posts
Top