GMC Truck Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have an 02. Sierra 2500 HD. I have no brake lights on the rear but I have my middle brake light. My taillight works on the right but not on the left. Both hazards, signals and reverse lights work. I ran a meter on the junction box for the left light but didn't get any reading. I checked all the fuses and they're fine Any thoughts on what it can be?
 

·
Mmm Sandwich
Joined
·
15,462 Posts
Check your 7 pin connector I bet it is corroded where it plugs into the main harness
 

·
Mmm Sandwich
Joined
·
15,462 Posts
Ok now lay on your back and pull the connector apart and you will see
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Here's a pic of the connectors. They look pretty clean. The bottom plug is the right side. I'm getting 10.5v on the 3rd pin on the top. I'm assuming that's the taillight since that's the only light working on the right side. I'm getting no other readings on any pin in either plug.
868638
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13
After spending a couple of days on this and not being able to figure it out I took it to a dealer. Cost me $300 and they have no idea. They said it's going to take them a lot more time to figure it out at a rate of $125/hr. I pulled my truck from the dealer. Back to square one
 

·
Registered
Joined
·
288 Posts
Have you swapped the rear connectors so you can confirm the working tail light moves to the other side? That way you know the problem(s) are further forward on the truck. BTW as weird as it seems, the brake lights are tied to the front turn signal circuit (or is it marker light, can’t remember) and if you put LED front lights in without load resistors, your main brake lights will quit working but your 3rd brake light will still work. I couldn’t figure out why my brake lights quit working and the last thing I had done was install led lights in the front so I swapped them back with regular lights and the brake lights worked again. Installed load resistors and I was able to run led’s.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
Hey Rocketman. I did swap the taillight and it works fine on the right side. Picked up the truck from the service dept today. My left marker light and left taillight now work. Still no brake lights. They told me that the fuse for the brake lights keeps blowing. When they put a new fuse in, the brake lights stay on and when they step on the brake pedal the fuse blows. I pulled the 10 amp fuse that says brake and it seems fine. Is there another brake fuse somewhere?
 

·
Mmm Sandwich
Joined
·
15,462 Posts
If it's popping fuses you have a short somewhere
 

·
Registered
Joined
·
288 Posts
No other fuse but like @Graystone said, you have a short somewhere. Pull your brake switch and see if the brake lights stay on. If so, it’s probably the switch but I don’t see how the dealer wouldn’t check that.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18
OK. So I can't find the blown fuse. The dealership told me their tech said it was the parking lamp fuse and he didn't replace the blown fuse. Which one would be the parking lamp fuse?
 
1 - 20 of 24 Posts
Top