GMC Truck Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter · #1 ·
I'm getting the Service 4WD light on my 2000 Escalade (think 1999 Tahoe/Yukon :D)...
I cannot make the truck go into 4 Low (light just blinks) and I cannot hear the front differential engage when I push 4 Hi (but it will change and light up)...
From what I can find here doing the search, it is quite possible that this is just the switch having the problem and not the differential...I have had intermittent lighting of the switch (2 Hi*Auto*4 Hi*4 Low) when the headlights are on so this seems to have just progressed...

The Problem: What is this part actually called and what is the part number???...mine has Lucas 551079 Z-0191 15027104 written on it but I have been unsuccessful in finding this part listed online...I plan to do the change myself so the dealership is probably out based on the last parts I needed, their pricing and so on...

I have found a part called the transfer case shift switch but that has no pic and other pics I found look like a mechanical switch and not this dash switch...another site showed a part listed as TCA22 for $120.79 but this also had no pic and seems to be the price of the part for the differential and not for the dashboard...

A check on the 'Bay showed one of these with no description on whether or not the part even works...

Any help would be appreciated...I am hoping to do what appears to be an easy swap out and hopefully fix quick...

Thanks,

Bill
 

·
Banned
Joined
·
1,500 Posts
try another autotrac switch from that year first. if it still doesnt work then its more than likely the actuator on the differential
 

·
Banned
Joined
·
1,500 Posts
try pm'ing denaliano. hes pretty much the man about stuff like this.
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #6 ·
I did have the right part number just looked at the wrong place...15027104 ...I hope this is the problem and not the solenoid...thanks,
Bill
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #7 ·
whichever it is, solenoid or switch (or both) it worked for a bit yesterday...I could hear/feel it engage the front differential but then it stopped working again...waiting on a price for the switch from one dealership and making an appointment to have it scanned at the place I get work done...

Thanks,

Bill
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #8 ·
new part number for the Transfer Case Control Switch if anyone interested...
19168765
My part will be enroute to me in the morning...
Thanks,
Bill
 

·
Registered
Joined
·
1 Posts
You can get the switch on Amazon.com for about $75 with free shipping. It is part tca13.

I've been getting "Service 4x4" warnings, flickering lights on the switch and difficulty-to-complete-failure shifting the t-case

I *just* soldered a joint on mine and put it back in the dash. This solved half my problem. The lights are solid again. I think i have a busted wire in my wiring harness. I twisted the switch around several times counter-clockwise to tighten-up the harness. It is working now. I'm sure this is very temporary and I will have to buy a new harness...

-Keith
 

·
Registered
Joined
·
166 Posts
Discussion Starter · #11 ·
Part arrived from UPS minutes ago...disconnected old switch...plugged in new switch...check for function: 2 Hi, Auto, 4 Hi, 4 Low...turn on headlights, switch backlights perfectly...and it is just that easy.

I had no idea GM still made this switch (19168765) and looked on ebay...for not much more than an unwarranted old part (probably has the same problem as mine as I read this is a common ill) off of ebay I have a new Genuine GM part installed and my 2000 Cadillac Escalade (Tahoe putting on airs ;) ) is back running like it should.

Thanks again,

Bill
 

·
Registered
Joined
·
1 Posts
Great post !

I think I have the same problem on my 2000 Escalade.

Nothing lights up on my Switch. I disconnect it and take a testlight to see if I'm having power and yes it light up. So I guess my switch is dead too !???
 
1 - 13 of 13 Posts
Top