GMC Truck Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
Hey guys, I've been working on my '97 non-stop since February by putting in a brand new Vortec 350, replacing all of the front end suspension pieces (bushings, bearings, ball joints, tie rods, etc), among other things.

After commuting ~25 miles to work and exiting, the truck shifted really hard into 2nd gear after leaving the service road light. It did it everytime it shifted from 1st to 2nd till I got to my office. What specifically could this be within the transmission or in the torque converter? Does it sound like I need to do a full transmission rebuild or is there anything else I can do?

After spending quite a bit $$ the last two months on it, the last thing I want is to have another $1500-$2000 bill for a new transmission or to have mine rebuilt. Any ideas would be appreciated.

-JP
 

·
Allison Specialist!
Joined
·
675 Posts
did you do anything with the tranny during the previous work you did?....If you were to need a rebuild pull it out yourself and bring it to the shop if you are able too. Much cheaper.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #4
did you do anything with the tranny during the previous work you did?....If you were to need a rebuild pull it out yourself and bring it to the shop if you are able too. Much cheaper.
Nothing was done with the tranny during the previous work. I was planning on doing the pull and re-install myself to reduce the cost.

and yes, I checked the fluid levels. Even ran a 24 oz bottle of Lucas "stop slip and hard shift" thru it. Still acting up when its been driving for a while and only during 1st and 2nd gear shifts
 

·
Allison Specialist!
Joined
·
675 Posts
Nothing was done with the tranny during the previous work. I was planning on doing the pull and re-install myself to reduce the cost.

and yes, I checked the fluid levels. Even ran a 24 oz bottle of Lucas "stop slip and hard shift" thru it. Still acting up when its been driving for a while and only during 1st and 2nd gear shifts
Only other thing i can suggest is maybe soemthing elcetrical in the valve body or possibly the tps sensor. Hopefully someone with more knowledge will chime in and point you in the right direction.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #6
Only other thing i can suggest is maybe soemthing elcetrical in the valve body or possibly the tps sensor. Hopefully someone with more knowledge will chime in and point you in the right direction.
thanks man for the input
 

·
Registered
Joined
·
1,144 Posts
my 96 is doig the same thing right now i checkedthe fuze to the trans on the dash and wasnt getting any power to it . i was told to replace my igniton switch the wiring harness under the steerign column i was toldif it was getting power tothetrans fuze to sheck the shift solenoids onthe trans and the elect. connections going to the trans for corrosswion or damage . i hope this helps .
 
1 - 8 of 8 Posts
Top