GMC Truck Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2011 Silverado 5.6 and I have always been concerned with the oil pressure seeming to show a low reading (approx. 30 lbs at hiway speed and approx. 20 lbs when idling at normal operating temp). The dealer has always assured me that this was normal with this engine due to the variable cam timing. Is this true and has anyone else had this problem?
 

·
Registered
Joined
·
730 Posts
Mine idles at 20 and gets up to 35-40 on the highway. Seems low to me too but I hear as long as you have 10psi for every 1000 RPMs you're ok


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
6,277 Posts
its within spec but on the lower spectrum. I idle at 35ish and im at 45-50 @ hwy speeds.
 

·
Registered
Joined
·
129 Posts
My truck Runs the same as yours 40ish hwy. At one time it did drop into limp mode and throw a code for low pressure but only once and have no idea why.
 

·
Registered
Joined
·
900 Posts
Silverado 5.6? Did you out a Nissan engine in it:insane2:
 

·
Registered
Joined
·
129 Posts
Did just figure out that GM put out a bulletin on the oil pressure sending unit. Mine went to shop for gear change and low oil pressure light came on with them twice test driving it. The bulletin talks about a small screen under unit that can get clogged easy. They changed mine while it was there and fixed low pressure issue. Mine still runs 30-40 as it did but no low pressure light.
 

·
Premium Member
Joined
·
6,277 Posts
the oil screen only applies to Gen IV motors....99-07c are Gen III and don't have screens under the units
 

·
Premium Member
Joined
·
6,277 Posts
Yes and he noted that he had a 2011 so would it not have a screen?
wasn't correcting u, chief :read:

gen iii guys have asked where the screen is at before :shrug:
 

·
00silvy
Joined
·
3,679 Posts
idk bout yall.... but I'd shit if my 4 year old truck was running 20psi at any rpm...
 

·
Registered
Joined
·
4,874 Posts
idk bout yall.... but I'd shit if my 4 year old truck was running 20psi at any rpm...
x2

my 200k tahoe is starting to get around 36-37ish now after getting to temp. Just replaced the oil pump with a melling unit summer 2013 and it's idled at at least 40+ never dipping down into the 30's even after warming up. Might be the royal purple i put in last spring is ready to be changed.. Gonna try amsoil this time around and see how it fares.
 

·
The Canadian
Joined
·
3,241 Posts
idk bout yall.... but I'd shit if my 4 year old truck was running 20psi at any rpm...
This.

My 14 year old truck gets 45 @ idle, and 50-55 at highway speeds
 

·
Registered
Joined
·
13 Posts
My 11' 5.3 never dropped below 40psi. I just changed the oil for the first time using valvoline and it drops to 20psi at idle when at operating temp. I'll be trying another brand...or just take advantage of my free changes at the dealer.
 

·
Premium Member
Joined
·
6,277 Posts
This.

My 14 year old truck gets 45 @ idle, and 50-55 at highway speeds
u also live in freezing temps...ud never see 45 @ idle in 120F summers like SoCal
 

·
The Canadian
Joined
·
3,241 Posts

·
Premium Member
Joined
·
6,277 Posts
hot idle, is hot idle for the most part
Negative...the oil will be cooler in ur neck of the woods than in socal summers....its not like a cooling system where temps arr controlled with thermostats and fans. Ambient temps and air flow play a big role in engine oil temps :)
 

·
Registered
Joined
·
129 Posts
My 11' 5.3 never dropped below 40psi. I just changed the oil for the first time using valvoline and it drops to 20psi at idle when at operating temp. I'll be trying another brand...or just take advantage of my free changes at the dealer.
What weight oil you running?
 
1 - 20 of 24 Posts
Top