GMC Truck Forum banner
1 - 9 of 9 Posts

·
TURBO!
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello fellas, my oil pressure senser isnt working so i bought a new one and i dont know how to get the old one out. I know its a 22mm or 1.1/16 and it need to be a deep thin walled socket but i just cant seem to get a grip on it. Just wondering if anyone else had this problem and has a tip on getting it out. im just temped to take it to the local gm dealer so they can deal with it because its on the back of the block, right behind the intake manifold. if anyone has any info for me please send it this way.

Thanks in advance.

Derrick
 

·
Registered
Joined
·
480 Posts
oil pressure sensors take a special sensor socket, get it at auto zone for like $7. its hard to make a regular socket fit right.
 

·
TURBO!
Joined
·
10 Posts
Discussion Starter · #8 ·
well my gauge reades max (550), i asked my brother who is a mechanic and he said it was the gauge. i pulled the sensor plug off to make sure its not the cluster and it is the sensor. i would get my brother to change it but i moved 2500 miles away from home.
 

·
Registered
Joined
·
6 Posts
Purchase the socket from Auto Zone...its still difficult but does require that socket. I think is was $10.00...I know this may sound silly but use an AC Delco filter as they have something inside that aftermarket and Frams do not have. I had a similar problem with a 2005, 2500HD. We changed the sensor and that did not work, changed the filter after talking to someone at the local Chevy store and it went back to normal. I had that chime coming on when the pressure was low...pain in the ass!
 
1 - 9 of 9 Posts
Top