GMC Truck Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter · #1 ·
Hey guys just finished the install of my KP Components 6 link... and ive come across a problem. I must not have set the pinion angle correctly like i thought i had. I set it at about 3 degrees. When i give the truck gas at anywhere from 20-60 mph i get vibrations. The vibrations were the reason i got rid of my 2 link for this setup.... and now they are back. maybe i just dont know how to set a pinion angle on a 2 peice driveshaft. Its an ext bad. If any of you have any thought of what the pinion angle should be... PLEASE inform me.
 

·
layin big rubber
Joined
·
1,457 Posts
is your center bearing in the stock location?

i moved mine up as far as i could when i had my djm 4-6 drop
and didn't do anything to it when i put my 6link in
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #3 ·
yes the center bearing is in the stock location still. set the bags to where the frame was perfectly level and measure the pinion angle at ride hight. Instead of the 3 degress i though i set. The front of the pinion was up dead on 2 degrees. i took a picture for reference.
IMG_7209.gif
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #4 ·
Ok, i figured it all out. i needed 2 degrees negative..... not positive. adjusted the bars and took it for a drive. no vibrations. Im extremely happy with the kit. it rides like a stinkin caddy!
 

·
Registered
Joined
·
23 Posts
i have the same problem with the vibrations but mine has negative degrees any ideas on that its not too bad but noticable enough mine is on a 2 link
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #7 ·
BINGO!!!! DING DING DING WE HAVE A WINNER!!!!!

yes, the two link is 100% responsible for the vibration. I hated mine, got the kp setup and can drive any hieght, any speed, just about anywhere, and never feel a vibration. KP is the only way to go.
 
1 - 7 of 7 Posts
Top