GMC Truck Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
503 Posts
Discussion Starter #1
its a 97 c1500 5.7 with 86K miles. sometimes when i start it up, it runs fine, starts fine. but like every other 10 starts it turns over for a while and just barely idles around 200 for a second or so then dies. sometimes it doesnt even start, it just dies right away. the last time it happend it took about 8 tries to get it started. even when it sounds like its boggin down and i give it gas it still dies. its throwing a code but i havent had a chance to check it. and then out of nowhere it'll start almost fine and when its running it runs just fine. no loss of power or anything. any ideas?? im thinking either fuel filter or fuel pump but the filter was replaced not too long ago. and ive ran injector cleaner a couple times to see if it helps. i need help quick so i dont have to worry about it anymore...
 

·
Registered
Joined
·
5,528 Posts
It always boils down to fuel, air and spark. Did you install the fuel filter in the correct direction? ( not being a dick, just happens often ) Check your air filter and see if it's clean. When did you last do your spark plugs? Pull a couple, different banks, and see how they look. Check all wires, PVC valve, hoses, etc. Amazing how a vehicle can crap out over "little" things.
 

·
Registered
Joined
·
503 Posts
Discussion Starter #3
did a tune up around 60K miles i believe. plugs, wires, pcv all that good shit. air filter looks decent. havent pulled the plugs yet. fuel filter is the correct way. gonna replace that this weekend to see if it helps. the last few days its started up just fine tho. and the ses light is gone now.
 
1 - 3 of 3 Posts
Top