GMC Truck Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
My dad's '88 1500 with the TBI 350 has been having some issues. At first the truck would run fine until you reached around 40 MPH and it would lose power and if you gave it gas it would try and die and occasionally backfire. Shut it down and let it sit for a minute and it would run fine. This lasted a couple of weeks but it got to where it would idle fine but if you tried to rev the engine it would stumble and backfire a flame up through the throttle body.

We parked it for a while and when I went to work on it it wouldn't start. Shot some starter fluid in it and it started up but would only run for a second and then die. I'm thinking that the fuel pump went out cause I can't hear it when I turn the key, but I'm wondering more about the symptoms it had before we let it sit for a while. Any ideas at what it might be?
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
My dad's '88 1500 with the TBI 350 has been having some issues. At first the truck would run fine until you reached around 40 MPH and it would lose power and if you gave it gas it would try and die and occasionally backfire. Shut it down and let it sit for a minute and it would run fine. This lasted a couple of weeks but it got to where it would idle fine but if you tried to rev the engine it would stumble and backfire a flame up through the throttle body.

We parked it for a while and when I went to work on it it wouldn't start. Shot some starter fluid in it and it started up but would only run for a second and then die. I'm thinking that the fuel pump went out cause I can't hear it when I turn the key, but I'm wondering more about the symptoms it had before we let it sit for a while. Any ideas at what it might be?


Many things come to mind:

existing state of tune (cap, rotor, wires, et al)
vac leaks
worn out TBI unit
injector issues
EGR
weak grounds
bad charging system

Start with the basic shit and work through it. Sounds like you have a dying/dead FP to start with... jump the relay and verify... it will not start w/o fuel.
 
1 - 2 of 2 Posts
Top