GMC Truck Forum banner
1 - 10 of 10 Posts

·
05 HD
Joined
·
43 Posts
Discussion Starter · #1 ·
hey guys i have a nbs hd with the 6.0 v8 with 55,000mi, my oil pressure gauge marks zero. its dipping below the red mark and i have no clue y:think::think:..........it does not do it all the time, but more often then not. I am wondering if its my actual gauge itself, but idk there is no weird noises coming out of my engine. The truck drives perfectly well and i see no change in performance either, so im stumped. i was wondering if any of u guys have come across this problem, and if so wat do u think it is...... any ideas guys thanx
 

·
05 HD
Joined
·
43 Posts
Discussion Starter · #6 ·
:rofl2: I should have specified. No, the stepper motor in your gauge cluster went out. You can buy new ones for cheap and solder them in.

If oil pressure was really that low, you'd notice problems.
yeah lol i was like fuck!!!! lol lol lo :roflsquared:
thanx man i think i might just buy the pod cluster that goes on your b pillar and buy some aftermarket gauges
 

·
05 HD
Joined
·
43 Posts
Discussion Starter · #7 ·
:rofl2: I should have specified. No, the stepper motor in your gauge cluster went out. You can buy new ones for cheap and solder them in.

If oil pressure was really that low, you'd notice problems.
:word: Chevy had a recall on the clusters. Dealership swapped mine out free, hit them up
nice!!! going monday morning hell yeah thanx man
 

·
Relentless Motorsports
Joined
·
1,222 Posts
i havent had that problem but it definately sounds like the gauge is bad. just get the dealership to replace it.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top