GMC Truck Forum banner

1 - 10 of 10 Posts

·
Banned
Joined
·
2,851 Posts
Discussion Starter #1
Battery on my Z71 was TOTALLY dead when I returned from offshore. No dash lights, no radio, zero, zip nada...

So I hooked it up to a batter charger overnight to charge up. While it was charging I swapped in my SS gauge cluster.

Once charged up it started right up and threw a Throttle Position Sensor code.
Having zero issues otherwise.

Dead Battery related? < maybe yes?
Cluster related? < leaning no

No code has returned since driving it.
 

·
Need Moar Low
Joined
·
2,286 Posts
Most likely dead battery related,ive seen my trucks do some odd things over the years, hopefully not TPS related it can be a a guessing came throwing random parts at it, since the pedal and TB all needs to work in sync, usually cause Reduce Engine Power.
 

·
Premium Member
Joined
·
6,277 Posts
#4.8problems
 

·
Banned
Joined
·
2,851 Posts
Discussion Starter #4

·
Premium Member
Joined
·
6,277 Posts
i threw a TPS code too...cleaned my TB and it went away

Edit: mine was P1516...dirty TB...it had gunk around the blade, guess it never hit 100% and it threw the code after a WOT pull.
 

·
Banned
Joined
·
2,851 Posts
Discussion Starter #6
Mine was a 120 or 122...

As soon as it popped up I immediately cleared it and so far no more issues...
 

·
This place sucks dicks
Joined
·
4,938 Posts
Soooooooo whats the question then?
 

·
Banned
Joined
·
2,851 Posts
Discussion Starter #8
Soooooooo whats the question then?
Wanting to know if a dead battery can inadvertently cause this code. Since I've never seen it before up to this point.
 

·
Registered
Joined
·
1 Posts
Hey Guys! I have a 2011 Silverado w/5.3 FlexFuel model. The check engine light has come on 2 times in the last couple months. I went to Advanced to get the code read out, and both times were MAP/Throttle Position Sensor codes :mad:...I need advise on what it could be causing the code.

Do I need to check/clean the throttle body? What about the TPS circuitry?

Any help is much appreciated. I love my Chevy :favorites37:

Frank
 

·
Registered
Joined
·
472 Posts
Hey Guys! I have a 2011 Silverado w/5.3 FlexFuel model. The check engine light has come on 2 times in the last couple months. I went to Advanced to get the code read out, and both times were MAP/Throttle Position Sensor codes :mad:...I need advise on what it could be causing the code.

Do I need to check/clean the throttle body? What about the TPS circuitry?

Any help is much appreciated. I love my Chevy :favorites37:

Frank
Don't be a thread jacker. Start a new one
 
1 - 10 of 10 Posts
Top