GMC Truck Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,570 Posts
Discussion Starter #1
Does anyone ever have a problem with your driveshaft or rear end making a noise when you let off the gas..Ok when I ride really low in the rear and let off the gas it makes sort of a grinding noise..I dont know if its the driveshaft or rear end..it only does it when you let off the gas..Once you get to about 15 mph or get back on the gas its stops..If I pick the truck up to a normal ride height it doesnt do it..Only when I'm really low..Someone said it was slack in the rear end or something.
 

·
LAID OUT TIRE FRYER
Joined
·
1,992 Posts
sounds like your pinion angle is too high. they say when you gas it the driveshaft shifts up a little bit. i think thats why there is the angle, not straight out or pointing up. i could be very wrong, but thats what ive heard or read on forums.
 

·
Registered
Joined
·
7 Posts
my s10 used to do that a little, only when i rode really low and when i rode up at stock height for some reason it didnt do it. same thing that is occuring with you. i never bothered with it and daily drove it and never had one problem. only thing is the noise is aggrivating. hope that helps ya out a lil bub
 

·
Registered
Joined
·
3,222 Posts
does it make a noise when you accelerate too?....if so it is prolly your u-joints...if not then check your pinion angle
 

·
Registered
Joined
·
1,570 Posts
Discussion Starter #6
No it only does it when I'm off the gas. I mean I've gotten use to it now I just don't know if it's messing anything up or whatever..plus when people ride with me their like dude I think something's wrong..haha
 
1 - 6 of 6 Posts
Top