GMC Truck Forum banner
1 - 10 of 10 Posts

·
SOLD
Joined
·
127 Posts
Discussion Starter · #1 ·
Ive got an '03 silverado and the compass/temperature wont show up on my rearview mirror. The mirrors' lights come on so its getting power but nothing shows up on the display. Any thoughts or ideas? Thanks
 

·
SOLD
Joined
·
127 Posts
Discussion Starter · #3 ·
checked the fuses, interior and under the hood and none of them seem to go to the rearview mirror, anyone have this problem?
 

·
Loves yoga pants
Joined
·
2,414 Posts
checked the fuses, interior and under the hood and none of them seem to go to the rearview mirror, anyone have this problem?
when i bought my yd the mirror didn't work nad it was a fuse nder the hood...i checked them all...found one blown and then it worked again...not sure exactl which one it was, but i do recall it was in the box under the hood.
 

·
SOLD
Joined
·
127 Posts
Discussion Starter · #6 ·
still nothing, checked all fuses under the hood, in the cab, plus the wire connections under the steering column but didnt have a tester on me.
 

·
Loves yoga pants
Joined
·
2,414 Posts
did someone press the buttom on the mirror that turns it on and off? hey...gotta throw out all possibilities...lol
 

·
SOLD
Joined
·
127 Posts
Discussion Starter · #8 ·
did someone press the buttom on the mirror that turns it on and off? hey...gotta throw out all possibilities...lol
heh ya ive checked that, even tried unplugging the mirror in the back and plugging it back in..sometimes the simplest things are the cause but not in this case
 
1 - 10 of 10 Posts
Top