GMC Truck Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
450 Posts
Discussion Starter · #1 ·
I got this message (service 4 wheel steer) when I started my truck on the way home. all three indiators (2,4, and trailer pic) lit up together. When I got home I turned the truck off and back on and the message did not come back on. I did not know at that time but, the manual shows I should have turned it off and on before driving. Could this be a serious problem or just a reminder to change the quadsteer fluid? 2003 GMC Sierra Xtd cab Quadsteer 4x4. 123,031 miles on it.
Thanks
 

·
Registered
Joined
·
47 Posts
I have been getting that message since almost new, randomly. The dealer looked at it and could not find any issues with it, except there "might" be moisture in the connections. All I do is shut the truck down, restart it and everything is fine for another year or so.
 

·
Registered
Joined
·
450 Posts
Discussion Starter · #3 ·
Well it's been a awhile but, the service 4 wheel steer message is back. it used to do it maybe twice a year. Now, it does it twice a day. I took it to a dealer and they looked it over. They said there was a GM service bulletin that stated they were aware of the problem and that there was no solution to it. I have read on another site that the steering motor can be replaced.

http://www.gmtruckclub.com/forum/sh...-Quadra-Steer-quot-Service-4-Wheel-Steer-quot


Should I try calling another dealer?
Also, could it just be the connectors?
Thanks,
 

·
Registered
Joined
·
9 Posts
I also read (via google search) that a number of folks have electrical connection issues. That might be a place for a do-it-yourselfer to start. Clean, dielctric grease and seal if possible. My just started going out of 4 wheel steer into 2 and with the "2" lit up and the same message on the dash. I've got an appt at the dealer for Monday. We'll see what they have to $ay...
 

·
Registered
Joined
·
9 Posts
My "Service 4-Wheel Steer" message comes on almost immediately anytime I put it into 4WS.

I put it into 4WS over the weekend to try it once again before going to the dealer. Turned a corner and the controller put itself back into 2WS but left the back wheels at an angle...that was fun crabbing down the street for awhile until I turned again and it straightened out. Dealer found a code C0522 and is recommending replacing the Rear rack position sensor. We'll see how that goes. More later...
 

·
Registered
Joined
·
1 Posts
JimmyB,
Did this fix your issue? I've been having the same issue for the past 6 months. Basically since I bought my 03 Denali Quadrasteer. It Typically occurs if I crank it hard to the right, the rear wheels lock in the angle position and I realize I'm crabbing down the road. The service 4 wheel Steer message pops. If I pull over, cycle the ignition, it straightens back out and I'm in business.

This has been occurring more and more often. It also happens sometimes when I back out fo the drive in the morning as I crank the wheel all the way one way the rear wheels lock up turned.

I'd love to be able to just fix this myself. I see $$$ signs for a dealer to even look at this.
Thanks!
 

·
Registered
Joined
·
9 Posts
Hi TJ,

Yes, replacing the rear position sensor solved that problem. That was Nov 2013. However it wasn't 6 month's later that I started hearing a little squeal every time I was turning while backing up especially. Eventually took it into the dealer and they diagnosed it as a gear in the quadrasteer unit that needs replacing. No parts for it are available. They are worried the gear might seize in an angled position so they disconnected the fuse for the quadrasteer. So now I essentially have a truck that works but no quadrasteer functions. How happy am I?
 

·
Registered
Joined
·
2 Posts
My Silverado 1500 quadrasteer sounds like it's binding up at slow speeds when I turn left or right in Reverse or drive what could be my issue tie rod end bearing somebody please help these rear ends are impossible to find and some of the sensors are very very expensive
 

·
Registered
Joined
·
1 Posts
Change out the differential oil. It’s specific from GM don’t use just any lube. Also make sure you can get the fill plug out first before draining.
if it’s chattering when in a slow turn that might help.
also if you take it to a dealer, be sure they use the called for lube.
 
1 - 12 of 12 Posts
Top