GMC Truck Forum banner

1 - 7 of 7 Posts

·
GM bit-size owner
Joined
·
1,654 Posts
Discussion Starter · #1 · (Edited)
Hello all, I just got this truck and have a few questions. 1999 gmc sierra, 5.3, ext. cab, full leather, full power, slt, with z71 sticker, don't think it's a real z71 though (no bilstien or locker) First off I got the truck dirt cheap, even trade for a $1000 street bike I had. It needed a rear end due to the pinion pin shearing the bolt off then the pin backing out and wacking the pinion gear. so I changed the rear end and now thats fine. next on my list is the service 4wd light is on and when I start the truck it automaticlly goes into 4hi. It won't just go into 2wd by hitting the button. the lights flash and you can hear the actuator trying but it fails and the 4 hi light goes back on. If I hit auto 4wd it on then I hit 2wd the light flashes then all go out and it's in 2wd. what could be doing this? switch or actuator or something else? also have a p0449 code for evap. anyone have a clue what could cause that? maybe the purge soleniod? Thank you ahead of time for your help.
 

·
GM bit-size owner
Joined
·
1,654 Posts
Discussion Starter · #2 ·
oh yeah, I forgot the security light keeps flashing too, and chimes go off with key out of the ignition, headlights off and drivers door open. and the dome light is on constant. any ideas?
 

·
Registered
Joined
·
300 Posts
that happend to my 2000 z71 all mine was a harness plug on the transfer case that was unplugged. i figured it out when i went to go get my exhaust done lol. but if i was to turn the truck off and turn the key foward itll put it in 2wd
 

·
GM bit-size owner
Joined
·
1,654 Posts
Discussion Starter · #4 ·
mines the opposite i shut it off and turn the on again it goes back into 4wd. what was the plug for? i'll have to look and see if they are all plugged in.
 

·
Registered
Joined
·
300 Posts
not really sure i just know it was on the transfer case
 

·
GM bit-size owner
Joined
·
1,654 Posts
Discussion Starter · #6 ·
well I brought it down to the dealership that I used to work at to get diag on the 4wd light and security light we'll just have to see what they come up with.
 

·
GM bit-size owner
Joined
·
1,654 Posts
Discussion Starter · #7 ·
ok so the 4wd light was really dirty connections. security light is a bad bcm. and the ses light is for the evap purge solenoid.
 
1 - 7 of 7 Posts
Top