GMC Truck Forum banner

1 - 6 of 6 Posts

·
Chevy Owner
Joined
·
1,363 Posts
Discussion Starter #1
Anybody ever had this thing come on in there NBS truck? About a month ago, this little message poped up and stayed there for like 2 min and went away :think:. Well, on my way home from work today, it came on again...but stayed on till I got home (about 15 min.). I was just wondering if this was just a common thing that happens in these trucks. I just turned over 50k on it last week. If its something serious and any of you have took it in, what did it turn out to be?
 

·
Drive It Like Ya Stole It
Joined
·
6,656 Posts
ya know mines on also, :crazy:


serisouly though, check to make sure your actuator is working and all 3 of your VSS are plugged in if you have autotrac.
 

·
heavy on the skinny pedal
Joined
·
1,732 Posts
also look to see if your switches for the fourwheel drive arn't lit up when the light comes on.
 

·
Chevy Owner
Joined
·
1,363 Posts
Discussion Starter #4
black4x4 said:
also look to see if your switches for the fourwheel drive arn't lit up when the light comes on.
The switch light doesn't change when it comes on. Everything looks and seems to be fine. All 3 of the plugs are plugged in and I would think my acuator is fine, because it has no problems engaging and disengaging in/out of 4wd. Maybe on of the plugs wiggled its way loose or something when i hit a bump...:think: i dunno. Must not be anything major cuz I just got back from a 2 hour drive and it never came on...we'll see i guess
 

·
Registered
Joined
·
464 Posts
Sometimes the Control, goes bad, thats the problem my friend was having with his 99 2500. It has autotrac, and after we replaced the control unit, the light stopped coming on....
 
1 - 6 of 6 Posts
Top