GMC Truck Forum banner

1 - 20 of 58 Posts

·
Registered
Joined
·
19,437 Posts
Discussion Starter #1
After I installed my shackles and hangers on my truck it was fine for a while but after a couple of weeks it started creaking and making all kinds of rackets. Well I check the shackles and the hangers and neither one are making a racket. Its in the springs. Anyone else have this happen? I sprayed everything down and it still made the racket but the only time it doent make it is when it rains! Anyone got a clue? I didnt take the spring pack apart or anything and everything is tight but not over tightened
 

·
Registered
Joined
·
19,437 Posts
Discussion Starter #4
Its like queaking creaking noise.. No thums or anything. I guess I'm gunna take it all apart when I do my notch and see if I can't get it figured out
 

·
Registered
Joined
·
19,437 Posts
Discussion Starter #7
I have some drop shocks on the rear till I buy new one all the way around... I'm gunna order spindles and a notch really soon so I'm gunna try and fix it when I do that. But it sounds terrible. My truck sounds like an old borke down pos
 

·
Registered
Joined
·
8,312 Posts
What brand drop shocks?

When i had belltech and dt shocks on they were pretty stiff and the springs would make clanking noise at the leaf spring c-clips. I shoved a few peices of rubber in the c clips to keep them from clanking and it helped until they fell out. No problems with the monroe shocks tho.

Jack up the rear of your truck, take off the wheels and try to shake the axle up and down. There is like a half inch space between the leaf spring and top of the c-clips. You will see what i mean.

Might not be your problem but i know it was annoying as shit for me.
 

·
I don't have a truck
Joined
·
10,439 Posts
You probably tightened the springs too tight, mine did that and I loosened them up, no problems.
 

·
Registered
Joined
·
19,437 Posts
Discussion Starter #12
Idunno I went back and checked everything and lossened everything then retightened but not very tight at all and it still does it
 

·
Registered
Joined
·
19,437 Posts
Discussion Starter #13
ok its the spring clamp things toward the front of the springs thats making the racket... i soaked them with some penatrating oil and they quit for a couple of days.
 

·
LAID OUT TIRE FRYER
Joined
·
1,992 Posts
do the same think you did with penetrating oil but with some lithium grease. it should last longer.
 

·
LAID OUT TIRE FRYER
Joined
·
1,992 Posts
when moddin begins, problems happen. The only thing that i could think of that causes this is that weight transfers and causes leaf springs to squeeze differently, making the clamp get noisy.
 

·
Banned
Joined
·
1,847 Posts
hahah wow this is my exact same problem!! i did the penetrating iol thing and it lasts for a bout two weeks at a time! its a pain in the asssss.....i gotta call a local spring company my buddy told me they can get a new bushing or what ever you call the rubber peice in their installed for pretty cheap i guess it will make it not squeak!
 
1 - 20 of 58 Posts
Top