GMC Truck Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
541 Posts
Discussion Starter #1
Was at the grocery store and when I came out, fired the truck up and started to exit the lot. Rpms dropped to about 2-300, lights dimmed, truck died. When i turn the key, theres a click click click thats very vague, inside the cab only, so the starter was not getting any power. Buddy comes to jump me and the truck fires back up and runs fine. Get to my house, turn it off to see what happens, and it won't fire back up, same thing. Alternator, battery, or what else?
 

·
Registered
Joined
·
5,528 Posts
Is it a faint, click click click? Power it is. Battery or things leading from the battery. Check the connections and make sure they are tight, as well as clean. A wire brush is your friend. Check the ground wire and connection. Then the wire to the starter. Good way to check the battery: Try to start with the headlights on. A good battery will still fire normally. A bad battery will probably leave you stranded.
 

·
Registered
Joined
·
5,528 Posts
Oh, and then you move on to the starter an check to make sure it isn't stuck. Love the GM bang-to-start starters.
 

·
Registered
Joined
·
541 Posts
Discussion Starter #4
won't light the headlights, but if i move the connectors around it'll light the headlight faintly. Might need to clean those off and go from there, but why would it all of a sudden die.
 

·
GMFS Resident Drunk Guy
Joined
·
704 Posts
Could also be the voltage regulator going bad. Where was the amp guage at during the ride home? Over-charging, under-charging, fluctuating?
 

·
Registered
Joined
·
6,189 Posts
Mine does that, it's the connection from the power cables to the battery (those stupid side posts). Make sure they have good contact and are fastened tightly. I'm in the process of converting mine to top posts for that very reason.
 

·
Registered
Joined
·
253 Posts
yep, even if the terminals look tight, under hook them and hook them back up, should be 8mm socket If i rememeber correctly (happened to me before :crazy: )

a litte steel wool and dielectric grease helped alot on my terminals
 

·
Registered
Joined
·
248 Posts
I think its the alternator went out. The battery doesn't have anything to do with the car remaining running. Once you fire it up you can take the battery out unless the alternator goes out and the car is basicaly running on the battery then which explains why the lights dimmed and you lose power until your jumped off again. You said you were already driving so that takes the battery out of the equation if the alternator is working. IMO
 

·
Registered
Joined
·
5,528 Posts
I think its the alternator went out. The battery doesn't have anything to do with the car remaining running. Once you fire it up you can take the battery out unless the alternator goes out and the car is basicaly running on the battery then which explains why the lights dimmed and you lose power until your jumped off again. You said you were already driving so that takes the battery out of the equation if the alternator is working. IMO
But his headlights won't come on unless he moves the connections around. That would be the battery. Not to say a bad alternator woin't kill a battery. Which is pretty much what it's best at.
 

·
Registered
Joined
·
541 Posts
Discussion Starter #14
Battery connectors were kindof corroded so i cleaned them off, still nothing. Hauled the battery to walmart and it was putting out 8 cold cranking amps, lol. Got a new one and its good to go. Thanks, thought it was the battery most of the time but it was showing some weird symptoms so I posted on here. :head:
 

·
it's not fast enough
Joined
·
1,677 Posts
mine did the same thing..but my truck wouldnt die unless i killed it..or stopped to fast...went got a new battery, and it was good.

we found a battery in a buggy and used it as a core then we went back with the one in my truck and used it as a core and got the money...it was nice having that 10.00 for no reason.
haha
 
1 - 16 of 16 Posts
Top