GMC Truck Forum banner
1 - 10 of 10 Posts

·
I like turtles
Joined
·
33 Posts
Discussion Starter · #1 ·
Hey guys have a problem n need some help. Went campin in maine on the saco this weekend with my 2001 tahoe. Took some dirt roads n a little bit of mudd from recent rain on the roads but nothin bad. Used my car for music for a while n drained the battery. I found the next morning after jump starting my car that none of the guages, except speedo, tach, and voltmeter work, nor does my ac/heat controls. the buttons dont even light up. The larger problem is that i have the auto push button 4wd selector which now doesnt work and im stuck in 4wd Hi. anything i should check before i gotta take it in to get it fixed?
 

·
DeepSouth Gangster
Joined
·
5,669 Posts
Checked fuses?
 

·
I like turtles
Joined
·
33 Posts
Discussion Starter · #3 ·
I have checked but havent visually seen any blown fuses. I forgot to mention that the cruise control nor the windsheild wipers function either. I just dont know what could wipe all these out at once?
 

·
AllOffTopic.com FTW!
Joined
·
8,460 Posts
That is a fuse, and IIRC it's not labeled well at all. I've had exactly that problem and I'm 99% sure that it was a badly labeled fuse.
 

·
AllOffTopic.com FTW!
Joined
·
8,460 Posts
That is a fuse, and IIRC it's not labeled well at all. I've had exactly that problem and I'm 99% sure that it was a badly labeled fuse.
I think I remember mine blew when I was fucking around with the radio and shorted its power wire, and it wasn't the fuse labeled "RDO" or "Radio" or whatever, it was something like "Interior lights".
 

·
Bayou Surface Drive, LLC
Joined
·
7,077 Posts
Pull all your fuses and visually inspect them. That is about the most advice I can give you.
 
1 - 10 of 10 Posts
Top