GMC Truck Forum banner
1 - 4 of 4 Posts

·
The ***
Joined
·
351 Posts
Discussion Starter · #1 ·
alrighty, just finished putting my rollpan on which turned out great. next day, when i was installing the light from the rollpan, i noticed that my drivers tail light and reverse bulbs were out, so i had some extras sitting around and i replaced them, the reverse still didnt work but the tail lights lit up fine when the brake was applied. Turn signal is ok too. so i took the light off, and removed the whole harness, took all the nasty ass electrical tape off, checked all the wires, the socket, the bulb housings, blew them out, cleaned, the whole nine yards, but still not working. any suggestions? i had a test light and a voltage meter, and neither of them registered on the tail and reverse. this is just annoying the crap out of me bc i do all my own work on the truck (no one has ever touched it since ive had it), fixin/installing everything and i cant fix a little taillight haha. im no electrician either, hell, im not even in college yet but still

here's the roll pan. matched perfectly for being an 02 paintjob:

 

·
The ***
Joined
·
351 Posts
Discussion Starter · #2 ·
anyone??? id rather not spend $108 for new wiring when i could spend that on whole new tail lights unless someone has any ideas...
 

·
The ***
Joined
·
351 Posts
Discussion Starter · #4 ·
ive tried new bulbs on everything since they are all the same.

edit: the old reverse bulb still works too, bc i put it into the turn signal and it was fine

and i found new bulb sockets on LMC truck so thats my first option as of now.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top