GMC Truck Forum banner

1 - 8 of 8 Posts

·
Banned
Joined
·
7 Posts
Discussion Starter · #1 ·
Need some advice for a gm th 400 that is leaking trans fluid from the speedo cable. I thought there was only suppose to be grease there. Trans only has 3,000 miles on it. Any help would be great. Thanks Chuck
 

·
Banned
Joined
·
7 Posts
Discussion Starter · #3 ·
everythings tight

EDIT there must be o-rings to hold the fluid back does anyone have a picture of a th 400 exploded view. that would help. If I could buy a manual I would but its a motorhome p30 chassis with gm drive train and can't just go buy one at the local parts store. Thanks
 

·
NCOR
Joined
·
8,451 Posts
If its' cross threaded it would be tight, just not correctly tight. I don't have a mech speedo unit to look at but my guess is they are tapered threads.
 

·
Banned
Joined
·
7 Posts
Discussion Starter · #6 ·
just went out and pulled it. cable wasn't cross treaded. its just a small round housing with a o-ring on the outside with a one piece gear that has a stem on it that goes threw the housing and connects the gear to the cable. so my guess the gear is worn out.
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
Positive the o-ring isn't cracked/torn/misinstalled?
 

·
Banned
Joined
·
7 Posts
Discussion Starter · #8 ·
When I first looked at the housing and the cable there was no fluid at the housing or on the trans but the cable had fluid ready to drip off it and when I pulled the cable fluid dripped out.
 
1 - 8 of 8 Posts
Top