GMC Truck Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I recently changed the transmission in my truck. (79 C20) I took the truck for a test drive and everything went fine. Currently, if I sit at a light for more than 20 seconds the truck shifts into neutral. If I rev the motor up a little it will jump back into drive.

The vacuum line for the truck is still the steel one but has seen better days.

I am looking at replacing the line first to see if the problem will be corrected.

Two questions:

Am I on the correct path to remedy the problem?
Can you replace the vacuum line completely with a rubber line? I am not sure where I heard it but I thought it was not recommended.

Thanks
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
I would eye your linkage before anything.

From the vac modulated trans I own/dicked with... the modulator mostly controls line pressure. High vac = soft shift, low vac = firm shift.

WOT is controlled by the governor in the tailhousing and part throttle shift timing by a TV/Bowden cable or other mechanical linkage (in your case the kick down, but the modulator itself sets part throttle timing I believe... at least it did on my pals TH350).

all I got :imo
 

·
Banned
Joined
·
2,342 Posts
check that vacuum line....possibly run a temporary line to see if that solves your problem. Had it come loose in my old 80 Z28 and the car would rev pretty high before dropping into gear until I figured out what was wrong
 
1 - 3 of 3 Posts
Top