GMC Truck Forum banner

1 - 20 of 37 Posts

·
Resident Guinea ***
Joined
·
14,535 Posts
got a camera that takes video w/sound? upload a vid so we can hear it.

It's probably something HVAC related, maybe. I know shit ticked in OBSeses.
 

·
Registered
Joined
·
81 Posts
hey my 2003 SSS does this too every once in a while it is some sort of relay clicking not sure exactly but everything works fine
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #6 ·
Al Queda :imo:
LOL, nah........it's just like pimp SS said. it only does it sometimes but nothing is wrong. I should probably try to find the relay. think it just needs to be replaced? I'd hate to have to pull the damn dash just for that though. ugh.

thanks guys. I'll try to take a vid/audio of it next time it does it.
 

·
GM Trucks & UA
Joined
·
1,635 Posts
Was it ever a fleet vehicle in it's previous ownership, might be a meter in there somwhere?

Also, have you noticed it doing it when it's raining or after just being washed?
 

·
haz 12"s!
Joined
·
4,531 Posts
My 04 have a knocking sound from the drivers side behind the dash. Its in the HVAC system. Its not all the time but its only on the a/c setting. I think its related to the sudden change from a/c to heat via the little door thing.
 

·
Cartmans Critters
Joined
·
8,867 Posts
Yea it could very well be a relay, my relay did the samething, all I did was replace it and it went away. The relay that I replaced was in the fuse box under the hood
 

·
Registered
Joined
·
6,253 Posts
I had the same thing on my g'pa's tahoe......I got under the drivers side floorboard one night and put some tape on it so I know where its coming from......its a lil thing thats geared and spins around I dunno....
 

·
NIGHT CREW
Joined
·
2,915 Posts
Mine does the same thing but i ahve yet to find the actual thing making the noise.
 

·
Registered
Joined
·
46 Posts
Mine does the same thing sometimes but it always goes away after a few clicks.
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #19 ·
I'm going to try and replace the relay under the hood to see if that fixes it. it's not the same thing if yours goes away after a few clicks. this doesn't go away until you turn the ignition off and restart it and then it's gone. pretty confident it's a relay like was mentioned earlier in my case.
 

·
Must be lost..
Joined
·
1,148 Posts
Could be the blend door motor, will it go away when the temp control is in the middle setting?
 
1 - 20 of 37 Posts
Top