GMC Truck Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I recently had my tow/haul function quit on me(99 e/c 4x4) but managed to find and cure the problem.What I found was a broken wire along side the steering column from the tow/haul button.Here's how I fixed it in case anyone else has this happen.
1: remove the lower half of the steering column cover,2 torx head screws and unsnap it from the upper half.
2: remove the dash trim,just pulls off.
3: drop the parking brake release handle,1 10mm bolt.
4: remove 2 screws,1 on either side of parking brake release,from large lower dash panel under steering column and pull it off.
5: reach in under steering column and unplug the 2 wire connector with orange covering.
6: pry off 1 wire loom and release the other with a screwdriver.
7: remove the torx head bolt holding the shift lever in place.
8: take the lever to a work bench and strip back enough wire to allow a good splice to be soldered in.
9: once thats done reverse steps 7 to 1 and your done.

Hope this helps.
 

·
RIP Jason
Joined
·
4,089 Posts
mine hasn't been working for the longest time then one day it started working. Next day it stoped :nono:

i need to try this but i don't have a soldering iron :think:
 

·
Registered
Joined
·
3,278 Posts
Can we get a sticky on this? It helped me repair mine this weekend.
 

·
Registered
Joined
·
866 Posts
Another vote for a sticky on this. Very common!
 

·
GMFS Member
Joined
·
1,034 Posts
Very common I fixed this on a buddy's truck...

STICKY :imo
 

·
Registered
Joined
·
13 Posts
This was an easy fix, after a bike ride to 2 stores to try to find the soldering iron. Never used one before. One more thing fixed on the truck.
 

·
Registered
Joined
·
2,836 Posts
Finally Found this damn thread lol :fuckyea: Needs a Sticky IMO.

Knew i searched and saw it before once.

Question??>>> would this still apply for me? My button only works every now and then. Its weird. Could it be bad connection or a bad fuse, and maybe not the wire that gets worn out?

Thanks for input!
 

·
Registered
Joined
·
3,278 Posts
Finally Found this damn thread lol :fuckyea: Needs a Sticky IMO.

Knew i searched and saw it before once.

Question??>>> would this still apply for me? My button only works every now and then. Its weird. Could it be bad connection or a bad fuse, and maybe not the wire that gets worn out?

Thanks for input!
Yes thats how mine started intermittently
 

·
Registered
Joined
·
2,836 Posts

·
Registered
Joined
·
3,278 Posts

·
Registered
Joined
·
2,836 Posts
Gotcha, so now yours it freaking out again?
 

·
Registered
Joined
·
3,278 Posts
I ended up buying a new shifter arm in 09 it worked for a while
 

·
Registered
Joined
·
2,836 Posts
Gotcha, So is this fix pretty easy... Im mechanically inclined btw
 

·
Registered
Joined
·
3,278 Posts
Gotcha, So is this fix pretty easy... Im mechanically inclined btw
Hardest part is not breaking the clips of removing the cover on the column
 

·
Registered
Joined
·
2,836 Posts
Thanks for the info
 

·
Registered
Joined
·
866 Posts
Yup this is very easy! I love these easy fixes.
 
1 - 19 of 19 Posts
Top