GMC Truck Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
My tranny shifts hard from 1st gear to 2nd if I slowly ease into the pedal. However if I put the hammer right down it shifts like a hot knife through butter. Very smooth. Tranny was just rebuilt. With less then 5k on the tranny sense rebuild. It's in a 91 K2500
 

·
Registered
Joined
·
332 Posts
I had the same issue when I had the trans rebuilt in my 06 Sierra, 4l60e. The 1-2 shift was so hard it felt like I was being rear ended. It seemed the easier I was into the pedal the harder it shifted. After they messed with it a bit it still shifted way to hard. They replaced it with a new one. The replacement still shifted too hard but it wasn't as bad. I now have about 10k on the trans and just recently it started shifting a lot easier from 1-2. It is still firm but feels good. With little pedal I can barely feel it shift. Maybe a trans guru can explain?
 

·
Premium Member
Joined
·
2,287 Posts
My tranny shifts hard from 1st gear to 2nd if I slowly ease into the pedal. However if I put the hammer right down it shifts like a hot knife through butter. Very smooth. Tranny was just rebuilt. With less then 5k on the tranny sense rebuild. It's in a 91 K2500
Sounds like the detent cable needs to be adjusted. check it before you smoke the trans.

alright thanks for the reply. may just need to get "broken in" hah
Highly doubt it
 

·
Registered
Joined
·
129 Posts
I have been reading on this and have that question myself. Mine was doing this shifting very hard between 1&2 then had it rebuilt worked for a long while know back to feeling like it is going to twist the ujoints in half. I would like to know if this can be fixed by a servo rebuild. Stock or Vette?
 

·
Premium Member
Joined
·
2,287 Posts
I have been reading on this and have that question myself. Mine was doing this shifting very hard between 1&2 then had it rebuilt worked for a long while know back to feeling like it is going to twist the ujoints in half. I would like to know if this can be fixed by a servo rebuild. Stock or Vette?
Your's is 2011 correct? different setup
 

·
Premium Member
Joined
·
2,287 Posts

·
Premium Member
Joined
·
2,287 Posts
Why go from not doing it to all at once doing it? And does this have nothing to do with servo? I'm not a transmission guy so just asking to learn.
Im not sure what you're saying. The detent cable basically tell the trans what position the throttle is in. More throttle= firmer shifting and later shifting.

Detent cable too tight= late, firm shifts
Too loose= smoked trans usually
 

·
Registered
Joined
·
129 Posts
Well it will do it no matter if im in the throttle or not. Just easying into it or hard in the throttle. It did it before then had it rebuilt then it started doing it again all at once. Not like something needs to be adjusted just started shifting like you are throwing it in second hard. Just from looking I can not find a detent cable on it. I used to have one on a firebird that would stick and I could pull on it get it untsuck and it would work. But cant find one on this 4l60e.
 

·
Premium Member
Joined
·
2,287 Posts
Well it will do it no matter if im in the throttle or not. Just easying into it or hard in the throttle. It did it before then had it rebuilt then it started doing it again all at once. Not like something needs to be adjusted just started shifting like you are throwing it in second hard. Just from looking I can not find a detent cable on it. I used to have one on a firebird that would stick and I could pull on it get it untsuck and it would work. But cant find one on this 4l60e.
should be on the pass side of the TB
 

·
Premium Member
Joined
·
2,287 Posts
What are you taking about. 4l60e is computer controlled. It is based of throttle position and vss reading.
93 should have a detent cable. mine did

also, it looks to be on the driver's side
 

·
Mmm Sandwich
Joined
·
15,708 Posts
Then it is not a 4l60e. You are thinking of a 700r4. They have TV cables
 

·
Registered
Joined
·
129 Posts
Then it is not a 4l60e. You are thinking of a 700r4. They have TV cables
That's what I was thinking, no detent cable on this one. The firebird I was talking about had a 700r4 and it did. However still have the same ? of will changing the servo fix this?
 

·
Premium Member
Joined
·
2,287 Posts
It just randomly started banging gears?
 

·
Premium Member
Joined
·
2,287 Posts
1 - 20 of 21 Posts
Top