GMC Truck Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter #1
Hey guys;

Got a strange problem I thought I might bring here before spending the outlandish service diagnostic fees at the shop; My issue is that the truck will drive fine for 20-30 minutes, no misfires, no slipping, no nothing, then when it gets good and warmed up and I think it's gonna go the distance, it starts to stutter badly and then will die if i let RPMS go too low, or stutter so badly that it dies anyway if i don't. Seems like it might have been bad gas, but I tossed some HEET and some b12 chemtool into it, and swapped out the MAF (just for good measure, since i just rolled over 100k and it'll probably go out soon enough anyway :)), but with no luck.
No codes being thrown whatsoever.


Anyway, any ideas on this? Very confusing, and I have to drag the boat about 50 miles this weekend and want to know i'm gonna make it!

Thanks in advance!

-Tony
 

·
JUGS Racing
Joined
·
1,199 Posts
Nore more info on the truck.
 

·
Registered
Joined
·
184 Posts
Discussion Starter #5
Don't i need to drop the tank to check the fuel pump in these trucks?

Had to take it to the shop...they're saying a back crank sensor. Looks like a pretty easy replacement, anyone done this?
 

·
JUGS Racing
Joined
·
1,199 Posts
No you hook up a fuel pressure gauge.

Crank sensors go bad and wont allow any spark or injector pulse.

How was that outlandish diag fee?
 

·
Registered
Joined
·
184 Posts
Discussion Starter #7
hahaa, yeah i'm sure i'll get faceraped for it. They're saying $100 for the part and ~150 for the labor...oh well. At least I'll know for next time.
 
1 - 7 of 7 Posts
Top