GMC Truck Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter #1
My 06 SSS has only 8600 miles on it. I have noticed within the past week or so that when I first start my truck it will idle for a second and just die. It will do this for about 3 cranks then it will fire up and stay running with no problems the rest of the day that I notice. I am thinking maybe dirty MAF sensor but really dunno since I am the furthest thing from a mechanic on here probably. I also noticed water dripping from my exhaust which I believe is normal but not sure about that either. I do have a custom tune so I would like to avoid a warranty redemption as to re flash my PCM so i will have to pay for a re-tune if i did that.
 

·
resident pyromaniac
Joined
·
7,498 Posts
My 06 SSS has only 8600 miles on it. I have noticed within the past week or so that when I first start my truck it will idle for a second and just die. It will do this for about 3 cranks then it will fire up and stay running with no problems the rest of the day that I notice. I am thinking maybe dirty MAF sensor but really dunno since I am the furthest thing from a mechanic on here probably. I also noticed water dripping from my exhaust which I believe is normal but not sure about that either. I do have a custom tune so I would like to avoid a warranty redemption as to re flash my PCM so i will have to pay for a re-tune if i did that.
who tuned your pcm?
 

·
Registered
Joined
·
248 Posts
Discussion Starter #3
who tuned your pcm?
PCM4Less has done it twice this particular tune was done the first of february and some think he set my idle to low but this didn't show its ugly self up until a few weeks ago so I just cant see a bad tune taking 2 months to show up but dunno.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #4
I got it fixed the MAF was dirty so I sprayed the piss out of it with electronics cleaner and the truck fired right up and idles so hard it rattles the windows again..Yeah Me.. :)
 
1 - 4 of 4 Posts
Top