GMC Truck Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
Since last week I got a problem with my truck.
If it just sits there and idles it just stops runnin. If it does that it's even hard to start it again.
It happend to me the first time, when i drove on the Autobahn for like 3 hrs and i had to stop because of a traffic jam. It just went out and barely started again. As long as i drive and it throttles (dunno if that's english?) it's runnin fine.
I cleaned the injectors as far as i could put injector cleaner in the gastank; changed out the O2-sensor; changed the egr. It ran fine for about an hour in my garage and 2hrs later it died again at an intersection...
Does somebody have an idea?
My buddysaid sth about the idle control valve? Where is that thing?

It's a 94 4.3 tbi with the vortec heads not the complete vortec intake.

Thanx guys!

Chris
 

·
Registered
Joined
·
5,528 Posts
Three things run gas engines: fuel, air and spark. Air is usually easy enough to find an issue with. Second is fuel. From the condition of the fuel, the pump, the filters, to pressure and injectors/carbs. Spark. The plugs, the wires and ignition coils/distributors' cao and rotors. Make your way through, see what you find.

Personally, I have found the caps to go bad more often than regular.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #4 ·
forgot to tell i changed the fuel filter first, cause i thought sth is clogged up.
took the airfilter off again yesterday and i was staring at the injectors till it stalled. right when it died there was no fuel injected, that's why i thought any relais or sth else is fu**ed up.

Chris
 

·
Allison Specialist!
Joined
·
675 Posts
yeah the idle air control valve sounds like a possibly culprit......Its on the opposite side of the throttle linkage behind the Throttle postion sensor, Its a big gold thing with a 2 or 3 wire connector....you could trying removing it and sparying some brake clean on it and see if that changes anything.....how old is the fuel pump?
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #6 ·
Thanx bro,
I even replaced it today. Truck ran fine for 5 mins then it stalled again.
died like 5 times in 3 mins and then it ran fine for over 2.5 hrs before it stalled again.
Feels f**kin unsafe to drive it. Don't wanna sit in the middle of an intersection and it doesn't start.
Fuel pump seems to be the original pump.
Does somebody have a wiring diagramm he could email me? I want to check out where the fuel pump relais is?
That's my last guess...

Thanx, Chris
 

·
Allison Specialist!
Joined
·
675 Posts
Well you should be able to hear the relay click if you turn the key all the way to one position but not start....Th relay is located on the firewall behind that black cover on the passenger side with two plastic screws on its...It say something like fuel center or something like that on the cover if i rember correctly......You know i just realized i didnt ask but Whens the last time your ignition been service, like the cap, rotor, plugs, wires?
 
1 - 8 of 8 Posts
Top