GMC Truck Forum banner

1 - 8 of 8 Posts

·
this
Joined
·
1,584 Posts
Discussion Starter #1
ive checked the ignition module..its good. I think all of my grounds are good but im going to double check. I know i got power going to the coil but im not sure if i got power going out? How can i test this?
Also- would a bad coil ground keep the coil from firing?
PICT0011.jpg


I have been trying to get my junk to crank for 6 weeks now and it is seriously starting to make me want to put some holes in the sheet metal
:banghead:
 

·
Registered
Joined
·
1,816 Posts
What exactly is it doing?

To test the coil what I would do is pull a plug, ground out the threads of the plug on the exhaust manifold or something and crank it over. If the plug fires, then your ignition system would be working. If not, I would work my way back from there.

Whats the pic supposed to be of? dist cap?
 

·
Registered
Joined
·
3,518 Posts
If your using that cap in that picture replace it. Buy a new cap/coil combo. But if you insist on using that thing then do as stated above and pull a wire and stick a good plug into it and ground the threads and see if you get spark.
 

·
Banned
Joined
·
487 Posts
willyswanter said:
If your using that cap in that picture replace it. Buy a new cap/coil combo. But if you insist on using that thing then do as stated above and pull a wire and stick a good plug into it and ground the threads and see if you get spark.

What he said... replace it.. and if you need tips on putting holes in teh sheet metal let me know. :anitoof:
 

·
GMFS Senior OG Member
Joined
·
3,511 Posts
Rednecked_4x4 said:
What he said... replace it.. and if you need tips on putting holes in teh sheet metal let me know. :anitoof:
Travis your the man on putting holes thru trucks :guns:
 

·
this
Joined
·
1,584 Posts
Discussion Starter #6
i got the ignition module tested and it is ok. I used a spark tester and nada, then i pulled the plug and put it against the header..nothing.
Ive got to contact MrGasket directly to order that fckn little metal piece in that pic..what a PITA :guns:
Im going to first try and clean that little POS and put everything back together see if that is it...if nto then i will just replace the entire top of the distributor.

so should i use .223, 00 12 guage buck shot, or .45?
 

·
this
Joined
·
1,584 Posts
Discussion Starter #8
fortuantely i didnt have to resort to high brass...

it cranked...it sounded weak but i didnt have the coil bolted down tight either.
hearing my truck run with open headers was like music to my ears!
but

the 3rd header pipe back on the passneger side (#5 ?)was smokin like a bitch.
It didnt smell like petroleum burning so i dont think it was just oil burning off. This was the side that had a little blue smoke coming out of the tail pipes after the truck idle for a while so:
SHIT
stuck or warped valve? or did my dumb ass just hook up the wrong plug wire? :think:
time to get out the block buster (.30-06)
 
1 - 8 of 8 Posts
Top