GMC Truck Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
736 Posts
Discussion Starter #1
Well i just got my truck back yesterday after i have taken care of the wreckless driving charge for doing dounuts. Right away i took it for a cruz, floored it a couple of times, seemed normal. Then today i was going to the mall, wheather was rainy, when i started the truck it started really rough, like a severe cold start, then i was coming out of a toll and punched it, nuthing happened, the engine and transmission shook horrible, the exhaust had a mild backfire sound, and it almost stalled. i got off the highway right away and headed to a gas station where i know some mechanics. On the way i kept giving the truck a little gas to investigate, everytime instead of downshifting the motor would rumble, it sounded like the rumble came from the tranny. it would shift fine but when i would give it gas it wouldnt downshift, just rumble and stall. when i got to the gas station, donnie, my friend would rev it in park and the thing rumbled and stalled. when i tried to start it again it would just rumble then stall. eventually it started back up, he said it sounded like a vaccume problem, but didnt know what else to do. so i went home. the truck drives perfect when the gas is applied gentle, but giving it too much gas causes it to rumble right through the tranny. it thought i had somethin cought up in the driveshaft cuase i swear thats where the noise is comming from. but the whole drivetrain shakes, esp. the engine. Anyone got ne ideas? its a 4.3L auto. 03 rcsb. I dout the dounuts i did have nething to do with this since it was a month ago, and i did them when the roads were soaked from water, so it wasent that harsh. plus driving the truck yesterday it was fine, i floored it and it was perfect. only today is it all fucked up. My dad is making an apt. tommarow at the dealership, the truck is under warrenty, but im curious if anyone has any ideas
 

·
Registered
Joined
·
89 Posts
I'm having trouble with my tranny in my rcLb 03 4.3L, nothing like what happend to you, but its nefiantly noticeable and getting worse. Let me know what happend and what the dealer tells you.
 

·
I don't own a lowrider
Joined
·
4,694 Posts
okie_in_cali said:
I'm having trouble with my tranny in my rcLb 03 4.3L, nothing like what happend to you, but its nefiantly noticeable and getting worse. Let me know what happend and what the dealer tells you.
What kind of problems are you having with your tranny? My dad's 03 4.8's tranny is jerky and seems to shift rough. He has taken it to the dealer three times now and they say it is "normal" My 00 doesn't do it at all, so it doesn't seem normal at all to me.
 

·
I'll Take teh Case!
Joined
·
1,918 Posts
low slow 00 said:
is it just me or is everyones 03's and 04's fuckin up?
My 03 isn't fucking up :anitoof: plus it's the same truck underneath as the 99+ model run :insane: (except my 5.3 has 285hp stock, while the 99 had 275 :crazy: )

Actually I've noticed tranny is starting to shift rougher than before, but I contribute that to too many pedal to the floor starts :burnout: I was talking about the transmissions in the truck with a service writer at the dealership the other day. He said they don't typically have much trouble with them, since the computer will adjust the shifting over time to compensate for wear and tear. Just though I'd share, but keep us updated on what happens...
 

·
Registered
Joined
·
736 Posts
Discussion Starter #10
well i have come to decide its something to do with my air flow sencor. cuz the truck keeps dumping gas into the motor like crazy. which would happen when the motor isnt getting the right airflow rating. but i havent done nething with it yet.
 

·
Registered
Joined
·
3,518 Posts
Unplug the MAF and see if it changes. I had a car come in that had a severe rough idle and wouldn't stay running, it would slowly drop rpms till it stalled. I unplugged the MAF and it smoothed right up, so I knew it was something to do with that. Ended up the owner cut the wires and then spliced them back together all backwards. If it stays the exact same with the MAF unplugged it's likely not that. If it is running rich like you said, could be o2 sensors, MAF, IAC, etc. Best bet is to get the computer scanned even if there is no SES light on.
 

·
Registered
Joined
·
89 Posts
What kind of problems are you having with your tranny? My dad's 03 4.8's tranny is jerky and seems to shift rough. He has taken it to the dealer three times now and they say it is "normal" My 00 doesn't do it at all, so it doesn't seem normal at all to me.
Jerky and shifts rough would be a good way to explain it, but it only did it a every once in a while a few months ago. Now it happens all the time. I'm afraid one day its just going to stop shifting all together. Also, I'm running a fatory G80 ( locking diff ), so I dont know if that has anything to do with it or not. Whats does your dad have in his?
 

·
Registered
Joined
·
2,120 Posts
Y2KSierra said:
What kind of problems are you having with your tranny? My dad's 03 4.8's tranny is jerky and seems to shift rough. He has taken it to the dealer three times now and they say it is "normal" My 00 doesn't do it at all, so it doesn't seem normal at all to me.
my truck does the same chit and they tell me the same chit :flame: its already had one new transmission

it mostly jerks when it drops down from second to first going around corners not everytime but if i drive semi aggresive it does it bad :flame: oh well if the fucker goes out they will put a new one in
 

·
I don't own a lowrider
Joined
·
4,694 Posts
Woah...so his truck isn't the only one having these shifting issues. tuckin22, how many miles did your truck have on it when they put the new transmission in and how did they finally come to putting a new one in? My dad's truck has around 6-7k miles on it now and it isn't getting any better.
 

·
I don't own a lowrider
Joined
·
4,694 Posts
okie_in_cali,

I'm not sure if he has limited slip or not. I want to say no, but i'm not positive on that. My truck has limited slip and it's never been jerky like his the few times I have driven it. I don't know what the deal is. Aren't most, if not all, of the electronics in the 03+ new?
 

·
Registered
Joined
·
89 Posts
Y2KSierra,

You got me on the electornics part, I want to say yes, but I dont know for sure. I talked to the dealer, they said it could be a number of things and it would just be best to bring it in and have them look at it. So, I guess i'll do that the next time I can.
 

·
Registered
Joined
·
736 Posts
Discussion Starter #18
Well i dropped my truck off, actually had it towed, to the chevy dealer today around 10AM, and they dont know what wrong with it. So its not gonna be an easy fix.............
 

·
Registered
Joined
·
2,120 Posts
Y2KSierra said:
Woah...so his truck isn't the only one having these shifting issues. tuckin22, how many miles did your truck have on it when they put the new transmission in and how did they finally come to putting a new one in? My dad's truck has around 6-7k miles on it now and it isn't getting any better.
my 03 had 5-6k on it when i finally took it in they kept it a month while i drove an 04 :naughty: they totally rebuilt the transmission and it still jerked while just regular driving from 1st to second and then second to thrird finally i said to hell with rebuilding it and they got the area gm rep involved and they slapped a new trans in it

it was fine for about 4k miles and then i noticed it harshly shifting when going around corners then acceralteing. hasnt done it lately so i have no clue and cant reproduce it everytime so there no use in carry it to the dealer except to let them now that the trans is not shifting right so when it gets bagged they cant blame the bags becasue of prior issues with the trans or i will have to brake out the :guns: or lawyers which ever one works
 

·
Registered
Joined
·
736 Posts
Discussion Starter #20
Well i just got the truck back, The distributer cap & rotor was shit. Dont know how it happened, back in the summer changing my spark plugs i crossed a wire and the motor back fired, but that was awhile, but im happy that it was fixed.
 
1 - 20 of 29 Posts
Top