GMC Truck Forum banner
1 - 10 of 10 Posts

·
Go5.3tt06
Joined
·
420 Posts
Discussion Starter · #1 ·
Hey. I really need your help. I am trying to help my cousin work things out his problem on 2005 Alvance Chevy truck. Its 5.3 liter only 85k mileage on it. Somehow he told me when he drive as roll from 0-55 mph start vabration. I told him let gas pedal off it was smooth. When you push the pedal its vabration. Then shift to Netural rev up some it was smooth. So drive its still vabration till about 60 or 65 mph it stop vabration. It could be missfire some spark plug. They never changed since they bought brand new ha.
 

·
Registered
Joined
·
1,570 Posts
All stock?
 
G

·
I don't own a truck that new, but don't these engines throw a check engine light when they misfire? How does it feel to you when you rev it up in park?

It sounds like you feel the vibration is coming from the engine, but is it possible it could be coming from the driveline? If it's an engine vibration, it will likely shake at roughly the same RPM through each gear. If it's a driveline vibration, you'll feel the shaking at certain speeds.

I would check the ujoints first. When was the last time the tires were rotated and balanced?
 

·
Go5.3tt06
Joined
·
420 Posts
Discussion Starter · #5 ·
Okay first of all we test at park to rev up. It was smooth. So I brake at shift d same time push some gas and brake pedal it not shake engine. The engine light haven't come on. So when we drove. We can feel the vibration somewhere middle of our seats. It possbile be driveshaft u joint? I can jack up and move the driveshaft. It will easy to tell if they loose? I remember when drove from 0 to 55 mph it shake so push a little more gas do the same. Truck rolled at 50mph and shift netural while truck is move. And rev up some it no shake on motor. So shift to D. It shake when I off the gas pedal its smooth. Unless if we go over 65mph no shake. Only 0 - 55mph
 
G

·
Yeah definitely sounds like a driveline issue. The first place I would look is the drive shaft ujoints.

Put the truck in neutral and set the parking brake. Chock the tires and get under the truck (no need to jack it up if you can crawl under for this). At each ujoint, grab the yoke of each shaft and work them in opposite directions. If there is any play at all in the ujoint, it needs to be replaced.
 

·
Go5.3tt06
Joined
·
420 Posts
Discussion Starter · #7 ·
Yeah definitely sounds like a driveline issue. The first place I would look is the drive shaft ujoints.

Put the truck in neutral and set the parking brake. Chock the tires and get under the truck (no need to jack it up if you can crawl under for this). At each ujoint, grab the yoke of each shaft and work them in opposite directions. If there is any play at all in the ujoint, it needs to be replaced.
Sure I will check it today and will let you know tonight
 

·
Go5.3tt06
Joined
·
420 Posts
Discussion Starter · #9 ·
Hey everybody. Here good news. Oh the height are stock. We inspection and the driveshaft front u-joint are crack. So we ahead replace both new u-joint. The vibration are GONE! It is all good news! Thank yall for help out.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top