GMC Truck Forum banner

1 - 8 of 8 Posts

·
i eat children
Joined
·
1,236 Posts
Discussion Starter · #1 ·
a couple day ago, i went out with some friends and i hit a mud hole pretty hard, and i got alot of mud in my front suspension and steering....


and it started to vibrate and pulling really hard, so i washed it down and all and it quit...acted normal....

today now, it started to viberate again, but its not pulling (like its out of alignment)


any ideas?


the truck is a 01 2wd ext. cab with the fabtech 7inch on it...
 

·
Senior Military Member
Joined
·
5,197 Posts
did you wash out the inside of your wheels? sounds like inbalance in rolling parts.
 

·
Registered
Joined
·
381 Posts
I'd check for any left over mud in the wheels or around the rotors. Even a small amount of mud can throw off the balance of the tires causing vibration. Additionally, your wheels and tires may now be out of balance if while wheeling you lost a wheel weight. I've had this happen to me before and I recieved a vibrate such as your describing.
 

·
Senior Military Member
Joined
·
5,197 Posts
Go get your tires balanced.
 

·
bitter southern gun owner
Joined
·
1,142 Posts
mighta knocked off your alignment and tie rods a bit if you hit holes to hard

had that happened to me before
 

·
Registered
Joined
·
117 Posts
some of the wheel weights could have even fallen off causing an imbalance...get them rebalanced, and be sure to watch them do it. They will hate you, and call you bad names when you leave, but the shit will be done right. Trust me, I work for discount and see shortcuts being made alot!
 
1 - 8 of 8 Posts
Top