GMC Truck Forum banner

1 - 13 of 13 Posts

·
RIP Jason
Joined
·
4,089 Posts
Discussion Starter #1
While i was in pismo i was going over some whoops and I framed pretty nicely and ever since then, i get a shitload of vibration from the heater box. I tried just vents, A/C, and heater and it'll still do it. I don't like this giant vibrator in the front of my truck so what can i do to fix it?
 

·
RIP Jason
Joined
·
4,089 Posts
Discussion Starter #3
lol thanks
This happens in my friends lowered truck but not as bad so it isn't that weird.
 

·
RIP Jason
Joined
·
4,089 Posts
Discussion Starter #5
C'mon...someone have any idea? I don't want to have to go to a dealership to get this fixed
 

·
thats right
Joined
·
1,399 Posts
if i had that adapter that let me reach through the internet and do everything for you i would, but until then you have to go out to your truck, look around and see if you can find what is broken. or if you have isolated a place, maybe pull part of the dash off and try to fix it.

the heater box should be down on the passenger side somewehre. you should be able to find it i think.

and isnt your truck an 02? what about warranty?
 

·
RIP Jason
Joined
·
4,089 Posts
Discussion Starter #7
it's an 00 that i got used...i havent really taken a look because i havent had the time. I just thought someone on here might have an idea...sorry to inconvience you with the question jeff...
Yah its a giant black box on the passenger side
 

·
thats right
Joined
·
1,399 Posts
zubyc said:
sorry to inconvience you with the question jeff...

i didnt mean to be a jackass. im just saying its next to impossible for anyone to find the problem over the internet
 

·
RIP Jason
Joined
·
4,089 Posts
Discussion Starter #10
Oh yah i know that...thats why I was just asking if someone has an idea of what could have happened
 

·
Drive It Like Ya Stole It
Joined
·
6,656 Posts
Jeff said:
if i had that adapter that let me reach through the internet and do everything for you

Dude did you see Belkin just came out with a new version? I ordered mine friday! :LOL: :crazy:
 

·
Fresno State Bulldog
Joined
·
5,708 Posts
Is it only when the fan is on?? If so, you may have something thats hitting the fan blades inside the blower....happend on my 97 when I first bought it, took about 30 minutes and it was fixed :)
 
1 - 13 of 13 Posts
Top